[racket] size_t and FFI?

From: Tony Garnock-Jones (tonyg at ccs.neu.edu)
Date: Sun Feb 10 18:52:53 EST 2013

On 2013-02-10 9:00 AM, Matthew Flatt wrote:
> I think that's likely to be right for all platforms where Racket runs,
> but we should define it in one place.


> Should we add `_size' to `ffi/unsafe', risking collisions with existing
> code?

This sounds best to me. (And while I think it should be _size_t, that
would be inconsistent with the existing _uintXY etc. Hmm. Never mind.)

There is no _size identifier in any of the current Racket codebase, so
no collisions there. Does anyone have a full greppable snapshot of
planet to check?


Posted on the users mailing list.