[plt-scheme] Should PLT Scheme have two R6RS namespaces?
Right now PLT Scheme provides the SRFIs in a immutable-list compatible
form. Correct?
This works well for using #lang scheme. It is ideal for that.
There is also a want for using pure R6RS implementation of the SRFIs
when using the #!r6rs language.
R6RS code should not use the immutable version of the SRFIs; it would
be a hassle converting between immutable and mutable lists.
Could we have a convention for, when using the SRFIs, that the
PLT'ized version have a regular number and R6RS specific versions have
the colon-prefixed number?
The next step would be getting the R6RS version into PLT but I am not
sure how to do that yet.