[racket] Planet crashing, hanging upgade during compilation

From: Robby Findler (robby at eecs.northwestern.edu)
Date: Mon Jun 28 11:37:35 EDT 2010

I'm having trouble seeing the bad behavior you see. One thing is that
installing racket doesn't install any planet packages, afaik. Perhaps
you can say more carefully what it was you did exactly?


On Sun, Jun 27, 2010 at 7:02 PM, synx <plt at synx.us.to> wrote:
> So I was installing racket yesterday and noticed that the installation
> was hanging on the sub-installation of a planet package. I looked at the
> situation, tried removing any proxies I might have set up, but nothing I
> could do would install that package. So I used 'raco planet url' to find
> the URL of the package, and then did something like this:
> http_proxy= wget -c
> 'http://planet.racket-lang.org/servlets/planet-servlet.ss?lang=%'
> Sure enough the file started coming in just fine, and then the server
> derped out somehow and left the connection hanging. I tried again, and
> discovered that planet does not support the HTTP Range header :c
> So I can partially download the file, anywhere from 10 to 20% of it,
> then my connection hangs. I don't think it's a problem on my side as I
> continue to browse other sites normally and this has been happening
> consistently only with planet.racket-lang.org for the last two days.
> Since the Range header isn't supported, I can't resume my download and
> have to start over every time. Ergo I cannot get the file, no matter what.
> A fix would be appreciated? ^.^; I dunno why it would be sending the
> file and just... stop partway through the connection. Out of memory
> error maybe?
> _________________________________________________
>  For list-related administrative tasks:
>  http://lists.racket-lang.org/listinfo/users

Posted on the users mailing list.