[plt-scheme] Re: can't connect to PLaneT on Windows XP machine

From: Gregg Williams (spamme at innerpaths.net)
Date: Thu Jul 30 14:26:59 EDT 2009

It's been a while since I've been on my Windows machine (I normally
use Mac OS X), so it took a while for me to remember to escalate to
the time-honored "reboot and see if that helps" strategy. It did--I
got a different error message. That experience reminded me to try the
next step: reinstall and see if that helps.

Once I did that, downloads from PLaneT worked first time. #*@$?#&
Windows.... Thanks for checking the server; that hadn't occurred to

On Jul 29, 10:46 pm, Jon Rafkind <rafk... at cs.utah.edu> wrote:
> Gregg Williams wrote:
> > I'm trying to get PLT Scheme to work on a Windows XP machine, and I
> > can't add needed modules from PLaneT. When I do so in the customary
> > way, I get the following error:
> > ---
> > require: PLaneT could not download the requested package: tcp-connect:
> > connection to planet.plt-scheme.org, port 80 failed (at step 4: An
> > operation was attempted on something that is not a socket.; errno=
> > 10038) in: (planet lizorkin/ssax:2:0/ssax)
> > ---
> Looks like its saying your local PLT client could not connect to the
> remote Planet server. I just checked (via telnet) and I can connect just
> fine. Maybe its just a transient error? How many times did you try to
> connect?
> Actually the error looks slightly more serious, what version of PLT are
> you using?
> _________________________________________________
>   For list-related administrative tasks:
>  http://list.cs.brown.edu/mailman/listinfo/plt-scheme

Posted on the users mailing list.