[plt-scheme] DrScheme fails to install on Ubuntu

From: Ben O'Neill (boneill at gmail.com)
Date: Wed Nov 2 08:50:38 EST 2005


I'm trying to use DrScheme on Ubuntu (breezy badger) and it's giving
me the following error during installation (using the ubuntu package
off the website):

Unpacking into "/home/ben/plt"... done.
Running the PLT installer...
./bin/mzscheme: relocation error: ./bin/mzscheme: symbol
__libc_stack_end, version GLIBC_PRIVATE not defined in file
ld-linux.so.2 with link time reference
Error: PLT installer failed.

Here's some version information I hope may help:

Linux version 2.6.12-9-386 (buildd at rothera) (gcc version 3.4.5
20050809 (prerelease) (Ubuntu 3.4.4-6ubuntu8)) #1 Mon Oct 10 13:14:36
BST 2005

ldd (GNU libc) 2.3.5
gcc (GCC) 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)

Thanks in advance for any help you can offer.

Ben O'Neill
boneill at gmail.com

Posted on the users mailing list.