[plt-scheme] Error during make install

From: Matthew Flatt (mflatt at cs.utah.edu)
Date: Thu May 8 10:29:34 EDT 2003

At Wed, 7 May 2003 19:55:01 +0200, Pieter Pareit wrote:
> setup-plt: Error during Compiling .zos for Setup PLT 
> (/usr/local/collects/setup)
> setup-plt:   load-handler: expected a `module' declaration for 
> `plt-installers' in "/usr/local/collects/setup/plt-installers.ss", 
> found: plt-installer-sig
> [...]

This looks like v204 has been installed on top of v203 (i.e., without
removing the v23 files, first). In particular, "plt-installers.ss"
isn't in v204.

The errors are relatively harmless, but you might want to delete each
file that Setup PLT complains about. (You'll have to run several
delete--setup iterations to reach a fix point, I think.)


Posted on the users mailing list.