[racket-dev] submodules

From: Jay McCarthy (jay.mccarthy at gmail.com)
Date: Fri Mar 9 21:54:09 EST 2012

I've renamed

module* to slice

and removed its ability to specify a language other than #f (maybe it
could be a #:keyword later)

I've removed when-testing because (slice test ...) is shorter than
(begin-for-testing test ...) [which, btw Carl, is the best name.]

I've expanded 'raco test' to support running a different submodule or
running the default module (what's a good name for it?) if the
submodule isn't there.

I intend to change DrDr so that it always uses "raco test -r" rather
than "racket -t".


On Fri, Mar 9, 2012 at 5:58 PM, Eli Barzilay <eli at barzilay.org> wrote:
> 30 minutes ago, Matthew Flatt wrote:
>> How about `facet', with the terminology that "facets" are
>> implemented as "submodules"?
> I like using a different term with just that explanation (ie, "a facet
> is a particular kind of a submodule").
> But I still don't like `facet' -- not only because of my non-native
> point, but also because it sounds to me like facets are distinct.  (So
> it's weird that one facet can require another.)
> How about just `slice'?  It sounds good on two levels: you split a
> module into several slices, and also you split each of this by small
> slices of code.  You'd read code as
>  (slice #|of|# main
>    ...)
> --
>          ((lambda (x) (x x)) (lambda (x) (x x)))          Eli Barzilay:
>                    http://barzilay.org/                   Maze is Life!

Jay McCarthy <jay at cs.byu.edu>
Assistant Professor / Brigham Young University

"The glory of God is Intelligence" - D&C 93

Posted on the dev mailing list.