[racket-dev] submodules

From: Eli Barzilay (eli at barzilay.org)
Date: Fri Mar 9 19:58:11 EST 2012

30 minutes ago, Matthew Flatt wrote:
> How about `facet', with the terminology that "facets" are
> implemented as "submodules"?

I like using a different term with just that explanation (ie, "a facet
is a particular kind of a submodule").

But I still don't like `facet' -- not only because of my non-native
point, but also because it sounds to me like facets are distinct.  (So
it's weird that one facet can require another.)

How about just `slice'?  It sounds good on two levels: you split a
module into several slices, and also you split each of this by small
slices of code.  You'd read code as

  (slice #|of|# main

          ((lambda (x) (x x)) (lambda (x) (x x)))          Eli Barzilay:
                    http://barzilay.org/                   Maze is Life!

Posted on the dev mailing list.