[racket-dev] Can't use 5.1.2 and later

From: Matthew Flatt (mflatt at cs.utah.edu)
Date: Sun Aug 28 22:04:28 EDT 2011

At Sun, 28 Aug 2011 13:18:36 -0600, Doug Williams wrote:
> I reported a problem a few weeks back that keeps me from using 5.1.2 (and
> now 5.1.3). Matthew believes it is due to an optimizer bug with boxes.
> Fortunately, 5.1.1 works, but we're stuck there. I tried the latest nightly
> build this morning and the error is still there.

I thought I had fixed that one with push d185c2a0df45 in the git repo.

The line

 (require (planet "williams/science/examples/science-test.ss"))

works for me (Mac OS X, 32-bit Windows, 64-bit Windows). Am I trying
the right example?

> Anyway, the real reason for this e-mail is that the latest nightly build
> (which was plt- gave me another problem. When I
> downloaded the science collection from PLaneT using the latest nightly
> build, it gave me errors about expecting a module for some files. There are
> indeed some rkt files that are included - using include - that are not
> modules. But, they are in the compile-omit-files in the info.rkt file. Is
> this being deprecated in some way?

I see that problem (i.e., errors when I use the `require' line above),
and it's related to recent changes for `raco link'. I've pushed a
repair in time for tonight's build.

BTW, the bytecode optimizer notices that `unsafe-fl*' is applied to
three arguments in "statistics.rkt". Looks like it's on line 713.

Posted on the dev mailing list.