[racket-dev] --enable-macprefix gone?

From: David Van Horn (dvanhorn at ccs.neu.edu)
Date: Tue Oct 19 22:29:52 EDT 2010

On 10/19/10 10:21 PM, Eli Barzilay wrote:
> Four minutes ago, David Van Horn wrote:
>> On 10/19/10 10:03 PM, Eli Barzilay wrote:
>>> 9 hours ago, David Van Horn wrote:
>>>> Has the --enable-macprefix option been removed from the configure
>>>> script?  When I configure, I get:
>>>>       configure: WARNING: unrecognized options: --enable-macprefix
>>>> If so, the src/README file should be updated to reflect the change.
>>> You should have this code in the "configure" script:
>> Yep -- the code's there, and if I omit the option the script gives an
>> error saying it's needed in order to use --prefix.  So why do I see an
>> unrecognized option warning when I provide --enable-macprefix?
> I just tried it, and it worked fine:
>    $ ./configure --enable-macprefix --prefix=/foo/bar
>    ...
> What's the command line that you're using?

$ ./configure --enable-macprefix --prefix=/Applications/plt

Looks like the warnings are coming from invoking the configure script 
for foreign/libffi:

=== configuring in foreign/libffi 
configure: running /bin/sh ./configure '--prefix=/Applications/plt' 
'--enable-macprefix' 'CC=gcc -m32' 'CPP=gcc -E -m32' 'CXX=g++ -m32' 
'CPPCXX=' --cache-file=/dev/null --srcdir=.
configure: WARNING: unrecognized options: --enable-macprefix
configure: WARNING: unrecognized options: --enable-macprefix


Posted on the dev mailing list.