[racket-dev] Thanks, Carl!

From: John Clements (clements at brinckerhoff.org)
Date: Tue Nov 30 14:52:03 EST 2010

Using (require (for-label (planet clements/rsound))) in my documentation just bit me in the butt really hard, when it turns out that installing a not-most-recent version of my planet package automatically triggers installation of the most-recent version, causing much pain for my students.  AAH! Fortunately, Carl's (this-package-in ...) form should prevent this in future.  If only I'd listened sooner...



-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4669 bytes
Desc: not available
URL: <http://lists.racket-lang.org/dev/archive/attachments/20101130/3ad1945b/attachment.p7s>

Posted on the dev mailing list.