[plt-dev] DrScheme v4.2.5 won't load Dracula

From: Carl Eastlund (cce at ccs.neu.edu)
Date: Sun Apr 11 19:04:53 EDT 2010

In the latest release, DrScheme freezes indefinitely when trying to
load the Dracula language level.  It worked in 4.2.4.x, it worked in
the release candidate I tried, and it works in on
the trunk, but not in the release.  I have narrowed the problem down
to the module path in the Dracula module-based-language-level's
"get-module" method.  If I change the module to be "scheme" instead,
the language level loads fine (aside from using the wrong module); the
GUI elements work fine, and so forth.

The module path causing the problem is (planet "dracula.ss" ("cce"
"dracula.plt" 8 10) "lang").  In both 4.2.5 and, I can require
this path into a regular "#lang scheme" window just fine if "populate
compiled/ directories" is off; I get a "module mismatch" error with
that option turned on (see PR 10685).

Does anyone know what might be causing this problem, and/or how I
might work around it between now and the next release?  Some students
using Dracula in Rex Page's class at the U. of Oklahoma ran into this
bug and I had to tell them to downgrade to PLT v4.2.4.

Carl Eastlund

Posted on the dev mailing list.