[plt-dev] performance-oriented unsafe operations (v4.2.1.8)

From: Faré (fahree at gmail.com)
Date: Mon Sep 7 14:11:57 EDT 2009

Maybe it's better to keep the very same name as the safe operation,
and let whoever imports it choose a different prefix. The immediate
benefit is that switching from safe to unsafe becomes trivial, which
is great for developing and testing in safe mode but delivering and
running in unsafe mode.

What will be interesting is to see if TypedScheme modules allow to
squeeze extra performance by expanding to unsafe operations.

[ François-René ÐVB Rideau | Reflection&Cybernethics | http://fare.tunes.org ]
If it's not worth doing right, it's not worth doing. -- Scott McKay

2009/9/7 Carl Eastlund <carl.eastlund at gmail.com>:
> On Mon, Sep 7, 2009 at 1:59 AM, Doug
> Williams<m.douglas.williams at gmail.com> wrote:
>> One other thing that is really just semantics.
> Actually, that's just syntax.  ;)
> On this list, semantics is the important stuff.
>> Would it be better to call
>> the operations 'unchecked-<whatever>' instead of 'unsafe-<whatever>'?
>> Generally, we are calling the function because we know it is safe to avoid
>> some constraint check - not because it is unsafe. Just a nit.
> --Carl

Posted on the dev mailing list.