[plt-dev] performance-oriented unsafe operations (v4.2.1.8)

From: Carl Eastlund (carl.eastlund at gmail.com)
Date: Mon Sep 7 06:20:50 EDT 2009

On Mon, Sep 7, 2009 at 1:59 AM, Doug
Williams<m.douglas.williams at gmail.com> wrote:
> One other thing that is really just semantics.

Actually, that's just syntax.  ;)

On this list, semantics is the important stuff.

> Would it be better to call
> the operations 'unchecked-<whatever>' instead of 'unsafe-<whatever>'?
> Generally, we are calling the function because we know it is safe to avoid
> some constraint check - not because it is unsafe. Just a nit.


Posted on the dev mailing list.