[racket-dev] raco pkg remove not removing

From: J. Ian Johnson (ianj at ccs.neu.edu)
Date: Thu May 30 12:59:37 EDT 2013

Quite right. You caught it. Thanks.
----- Original Message -----
From: "Matthew Flatt" <mflatt at cs.utah.edu>
To: "J. Ian Johnson" <ianj at ccs.neu.edu>
Cc: "J. Ian Johnson" <ianj at ccs.neu.edu>, "dev" <dev at racket-lang.org>
Sent: Thursday, May 30, 2013 12:42:18 PM GMT -05:00 US/Canada Eastern
Subject: Re: [racket-dev] raco pkg remove not removing

Does `raco link -l' show any trace of the old package (which would
suggest that the package manager failed between the points of removing
its own registration of the package and removing the link)?

If the package install was not installation-wide, then all state should
be in your "add-on" directory as reported by `(find-system-path
'addon-dir)'. The links are in "links.rktd", and package files are in
"pkgs" or "pkgs" inside a directory whose name is a version number.

At Thu, 30 May 2013 11:38:05 -0400 (EDT), "J. Ian Johnson" wrote:
> Following Asumu's advice, I used --force. I got the same error, but then it 
> was no longer installed. I tried to install again with the fixed files. It's 
> still looking for a directory for-accumulate! There's nothing in my repository 
> that references that name anymore. I'm quite confused. Are there some latent 
> files downloaded by the package manager that are being used when they 
> shouldn't? If so, that's a bug. Additionally I would want to know where they 
> are so I can delete them to work around the problem currently.
> -Ian
> ----- Original Message -----
> From: "J. Ian Johnson" <ianj at ccs.neu.edu>
> To: "dev" <dev at racket-lang.org>
> Sent: Thursday, May 30, 2013 11:31:25 AM GMT -05:00 US/Canada Eastern
> Subject: [racket-dev] raco pkg remove not removing
> I tried to turn my nifty-macros repo into something that the new package 
> manager could work with. I recently changed for-accumulate.rkt to for-acc.rkt 
> but forgot to change main.rkt to require and reprovide from the new file. I 
> installed from github and it died on looking for the for-accumulate directory. 
> This is weird since nothing referred to the directory - it was all the files. 
> Even so, I changed main.rkt to reflect the changes and tried to install. No 
> go, the package was already installed (albeit incorrectly). I try to remove. 
> It has the same error and fails to remove the package. I'm now stuck. How to I 
> remove an incorrectly installed package?
> -Ian
> _________________________
>   Racket Developers list:
>   http://lists.racket-lang.org/dev
> _________________________
>   Racket Developers list:
>   http://lists.racket-lang.org/dev

Posted on the dev mailing list.