[racket-dev] arity error with latest from git

From: David Van Horn (dvanhorn at ccs.neu.edu)
Date: Tue Jul 17 17:14:12 EDT 2012


I'm getting an arity mismatch error whenever I run a saved file in DrRacket.

Welcome to DrRacket, version [3m].
Language: racket [custom]; memory limit: 1024 MB.
. . ../../racket/collects/drracket/private/module-language.rkt:373:8: 
standard-module-name-resolver: arity mismatch;
  the expected number of arguments does not match the given number
   given: 1

The error points to line 376 of 
collects/drracket/private/module-language.rkt, which applies 
(current-module-name-resolver) to one argument.  According to the docs, 
and procedure-arity, that's not an acceptable number of arguments.

As of this morning I had a 3 day old build that worked fine, but I don't 
see anything (from a quick glance) that could have caused this. 
Moreover, that seemingly bogus one-argument call to 
(current-module-name-resolver) has been there for a long time so I don't 
understand why this is happening now.

Any ideas?  As it is, I can't do much of anything in DrRacket.


Posted on the dev mailing list.