[racket-dev] [plt] Push #24958: master branch updated

From: Robby Findler (robby at eecs.northwestern.edu)
Date: Thu Jul 12 15:09:54 EDT 2012

On Thu, Jul 12, 2012 at 1:28 PM, Matthias Felleisen
<matthias at ccs.neu.edu> wrote:
> On Jul 12, 2012, at 2:19 PM, Robby Findler wrote:
>> On Thu, Jul 12, 2012 at 1:14 PM, Matthias Felleisen
>> <matthias at ccs.neu.edu> wrote:
>>> Robby, could you share w/ us why you don't like the tool designation for the Optimization Coach and the Future Visualizer? Or if you can't articulate the dislike for 'tool', can you say what a better word is?
>> - I think the creation of a tool collection at this point is not great
>> because there will be lots of tools that are not in it.
> Are you saying that because we already gave > 110 collects it is too late to do anything about the bushiness of the tree? That's kind of sad.

It is very sad.

Relatedly, sticking these two together under the name "tool" does not
really help unless you have a plan to stick more there. Having two
different, half-followed conventions is worse than one bad convention.

>> - "tool" has often been a synonym for "drracket plugin" and the future
>> visualizer is not a drracket plugin.
> I accept that you think 'tool' alludes to 'drracket plug in' in our community, but I will say that when I was growing up 'ls' 'wc' 'find' and friends were 'tools' and you composed them with '|'.  Later I considered 'emacs' a tool but it was extensible; the 'scheme' mode wasn't a tool.
>> (I see some merit in trying to find a name for a collection having to
>> do with performance related tools, but "tool" is the wrong name for
>> that collection since it is too generic of a name.)
> I don't think it is about performance directly but indirectly. The two 'tools' we're discussing are 'inspectors' that help you find out what's going inside of Racket's compiler and during an execution with futures.

I wouldn't mind a word that has more specificity than "tool"; even
better if there weren't already N of them in separate places in the
collects that cannot be moved.


Posted on the dev mailing list.