[racket-dev] possible bug in openssl/mzssl

From: Neil Van Dyke (neil at neilvandyke.org)
Date: Wed Feb 29 12:37:20 EST 2012

Matthew Flatt wrote at 02/29/2012 11:20 AM:
> So far, I haven't managed to replicate the problem on my machine. Do
> you have any hints on how to configure Apache to trigger the problem or
> a server that I might try?

I'm afraid I don't have that test setup or notes anymore.  I do recall 
it was with PLT 4.2.5 (CGC collector) on Debian Stable (Lenny) 32-bit 
x86 machine with the Apache that Debian packaged, in a pretty stock 
configuration.  (This was likely also tested on other systems, but I 
can't say for certain.)  As noted in the email thread back then, every 
other HTTPS client tool I tried with the same files and server worked 
fine.  It's possible that I made a bug in the Scheme code, but 
everything I did was pretty straightforward, and I could not see a bug.  
Unfortunately, I couldn't share a complete test case for a PLT bug 
report at the time, or perhaps we could have figured it out then.


Posted on the dev mailing list.