[racket-dev] wrong line marked as source of error?

From: Marijn (hkBst at gentoo.org)
Date: Tue Oct 18 09:39:18 EDT 2011

Hash: SHA1

On 10/18/11 14:09, Robby Findler wrote:
> Oh, and one more comment: did  you try clicking on the left-hand 
> little red icon? That shows you the part of the stack that is in
> other files (if there is any to be shown).

I did try that, but it didn't show anything outside my one file.

> On Tue, Oct 18, 2011 at 6:36 AM, Marijn <hkBst at gentoo.org> wrote:
>> Hi list,
>> while running some code I'm working on, I noticed that the error
>> message reported and the expression highlighted as the source of
>> the error don't seem to match. The error produced is correct, but
>> the line recognized as the source is quite suboptimal. I've tried
>> to cut down on the number of lines in the file by removing
>> uninvolved code, but haven't tried to rewrite beyond that. I've
>> attached the code and a screenshot of my drracket exhibiting the
>> problem. Racket used is this morning's git version.
>> Marijn
>> _________________________________________________ For
>> list-related administrative tasks: 
>> http://lists.racket-lang.org/listinfo/dev

Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Posted on the dev mailing list.