[plt-dev] DrScheme v4.2.5 won't load Dracula

From: Carl Eastlund (cce at ccs.neu.edu)
Date: Sun Apr 11 19:33:51 EDT 2010

Thanks for the quick answer, Matthew.  I tested it out, and you are
correct -- the change in 18744 makes the difference.  I'll let Rex
know it's a DrScheme bug, rather than a Dracula bug, and his students
will have to stick with 4.2.4 until a new release comes out.

Carl Eastlund

On Sun, Apr 11, 2010 at 7:14 PM, Matthew Flatt <mflatt at cs.utah.edu> wrote:
> This sounds like the bug fixed in 18744. That bug was, unfortunately,
> introduced late in the process while finally fixing the
> problem that caused DrScheme to sometimes report an undefined-variable
> error on startup.
> Call it a problem in reaching a fixed point during release testing, or
> just call it my fault.
> Between this problem and various compilation problems related to
> compiling futures under Linux, maybe we should consider an early
> bug-fix release for 4.2.5.
> At Sun, 11 Apr 2010 19:04:53 -0400, Carl Eastlund wrote:
>> In the latest release, DrScheme freezes indefinitely when trying to
>> load the Dracula language level.  It worked in 4.2.4.x, it worked in
>> the release candidate I tried, and it works in on
>> the trunk, but not in the release.  I have narrowed the problem down
>> to the module path in the Dracula module-based-language-level's
>> "get-module" method.  If I change the module to be "scheme" instead,
>> the language level loads fine (aside from using the wrong module); the
>> GUI elements work fine, and so forth.
>> The module path causing the problem is (planet "dracula.ss" ("cce"
>> "dracula.plt" 8 10) "lang").  In both 4.2.5 and, I can require
>> this path into a regular "#lang scheme" window just fine if "populate
>> compiled/ directories" is off; I get a "module mismatch" error with
>> that option turned on (see PR 10685).
>> Does anyone know what might be causing this problem, and/or how I
>> might work around it between now and the next release?  Some students
>> using Dracula in Rex Page's class at the U. of Oklahoma ran into this
>> bug and I had to tell them to downgrade to PLT v4.2.4.
>> Carl Eastlund

Posted on the dev mailing list.