[plt-dev] Re: Build problems

From: Anton Ertl (anton at mips.complang.tuwien.ac.at)
Date: Mon Nov 9 15:33:52 EST 2009

Anton Ertl wrote:
> So I first tried to build mz-4.2.2 (and then, but no change)
> on an bunch of machines.  It worked nicely on a IA32 Debian Sarge
> system (gcc-3.3.5), but I had trouble on the other systems.  I will
> investigate these problems myself, but if this rings a bell for you, I
> would be glad for a hint.  Thanks in advance,
> - anton
> On a PowerPC (shown here) and AMD64 system running Debian Lenny
>   (gcc-4.3.2) I see:
> make[7]: Entering directory `/localtmp/mz-'
> gcc -g -O2  -Wall  -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I./../mzscheme -I../../foreign/../mzscheme/include -I../../foreign/../mzscheme/src -Igcc/libffi/include -c ../../foreign/foreign.c -o foreign.o
> In file included from ../../foreign/../mzscheme/include/scheme.h:127,
>                  from ../../foreign/../mzscheme/src/schpriv.h:21,
>                  from ../../foreign/foreign.c:9:
> /usr/include/stdio.h:34:21: error: stddef.h: No such file or directory
> In file included from /usr/include/stdio.h:75,
>                  from ../../foreign/../mzscheme/include/scheme.h:127,
>                  from ../../foreign/../mzscheme/src/schpriv.h:21,
>                  from ../../foreign/foreign.c:9:
> /usr/include/libio.h:53:21: error: stdarg.h: No such file or directory

I found a workaround for this: After configuring with

../configure CC=gcc-4.3

this compiles fine on both of these machines.  Only when invoking the
compiler with "gcc" do I get this error message; and that's despite
that fact that gcc is just a symbolic link to gcc-4.3.  Apparently the
name of the command I used is used in the path lookup.  Strange.

I cannot currently test on the Alpha box.

- anton

Posted on the dev mailing list.