[plt-dev] weird error; contracts for xml error

From: Matthias Felleisen (matthias at ccs.neu.edu)
Date: Sat May 30 14:17:25 EDT 2009

1. what does this really mean:

> Making Web pages in /Users/matthias/0Unison/0Web/
> link: module mismatch, probably from old bytecode whose  
> dependencies have changed: variable not provided (directly or  
> indirectly and at the expected position) from module: "/Users/ 
> matthias/plt/collects/xml/private/reader.ss" accessed from module:  
> "/Users/matthias/plt/collects/wxme/xml.ss" at source phase level: 0  
> in: provide/contract-contract-id-read-xml.2

This happened right after I ran setup-plt -l xml.

2. here is a contract error, which I believes illustrates the  
"pressure of contracts" conjecture:

> Making Web pages in /Users/matthias/0Unison/0Web/107-f08/
> (file "/Users/matthias/plt/collects/xml/private/reader.ss") broke  
> the contract
>   (->
>    (or/c location? symbol? #f)
>    (or/c location? symbol? #f)
>    symbol?
>    (or/c permissive/c string?)
>    attribute?)
>  on make-attribute; not in permissive mode

So this seems to mean a (permissive? #t) is missing from reader.ss. I  
added it and 'it works now' but I don't think that's the proper way  
to go about it. 

Posted on the dev mailing list.