[plt-dev] Re: Pre-Release Checklist for v4.2.1

From: Doug Williams (m.douglas.williams at gmail.com)
Date: Tue Jul 21 13:14:37 EDT 2009

Eli, this seems to be related to the old Vista problem we had before (I
think it was Robby that tracked it down) with the virtual store. On Vista,
if system files are re-written, the updated copy is written in the Virtual
Store - not to the file itself. Unfortunately, these persist over installs
of PLT Scheme.

In Linux, this manifests itself as not being able to write to /usr.

It seems that setup-plt is rewriting the index wherever the distribution is
loaded. I thought it was writing it to a user file before.

I think the discussion was off the mailing list - anyway, I didn't find it
when quickly looking through the archives.

On Tue, Jul 21, 2009 at 10:31 AM, Doug Williams <
m.douglas.williams at gmail.com> wrote:

> It happened for every package I tried - five total.
> On Tue, Jul 21, 2009 at 10:30 AM, Eli Barzilay <eli at barzilay.org> wrote:
>> On Jul 21, Doug Williams wrote:
>> > With the release candidate, I encountered the following error when I
>> tried
>> > loading the science collection using (require (planet
>> > williams/science/science)):
>> >
>> > setup-plt: given collection path: #<path:scribblings\main\user>
>> > refers to the same directory as another given collection path
>> > [...]
>> I just saw that error in one of the test runs, and assumed it was very
>> rare to run into it.  Do you reliably get the problem?
>> --
>>           ((lambda (x) (x x)) (lambda (x) (x x)))          Eli Barzilay:
>>                    http://barzilay.org/                   Maze is Life!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.racket-lang.org/dev/archive/attachments/20090721/ddb1f2ff/attachment.html>

Posted on the dev mailing list.