[plt-dev] searching for bitmap% via f1 on mac os x

From: Eli Barzilay (eli at barzilay.org)
Date: Sat Feb 28 07:28:06 EST 2009

On Feb 28, Robby Findler wrote:
> When I searched for bitmap% by putting my mouse on the word and
> hitting f1 in drscheme, I got this:
> browser-run: process execute failed: (#<path:/usr/bin/osascript> "-e"
> "open location \"file:///Users/robby/Library/PLT%20Scheme/\"")
> My shell reports
>   Unmatched ".
> when I just try those arguments.  When I try this commandline it
> works great:
> osascript -e 'open location
> "file:///Users/robby/Library/PLT%20Scheme/"'

Weird.  After trying some things, I think that:

* The `unmatched' error that you get when you run it in your shell is
  probably because you're using tcsh (which is, IIRC, the default on
  OSX).  You probably get the same result for

    echo "foo \"bar\" foo"

  [And BTW, tcsh is a terrible choice for a shell, as I was reminded
  by googling for "tcsh quotes" which got me quickly to
  http://www.grymoire.com/Unix/CshTop10.txt -- with enough hair that
  should make you scream in horror.]

  [I usually recommend zsh these days, but even bash is better if you
  want to use your shell in any way that is an epsilon above complete
  naive things.]

* The second one worked fine, because happens to mean what you think
  it does in tcsh.  (As well as in other shells.)

* If the above is correct, then the "process execute failed" is due to
  some other problem (it doesn't use a shell on OSX).  (And I don't
  have a clue what it might be.)  Probably similar to the problem that
  Matthias had a while ago.

* And BTW, if you grep that thread, you'll see that we went through
  the same story...

          ((lambda (x) (x x)) (lambda (x) (x x)))          Eli Barzilay:
                  http://www.barzilay.org/                 Maze is Life!

Posted on the dev mailing list.