[racket] FFI require statement

From: Harry Spier (vasishtha.spier at gmail.com)
Date: Wed Jul 25 11:18:47 EDT 2012

The FFI require statement for the ImageMagick FFI is
"(require mzlib/foreign) (unsafe!)"

mzlib/foreign.rkt contains:
(module foreign racket/base
  (require scheme/foreign)
  (provide (all-from-out scheme/foreign)))

The FFI documentation says to use:
"(require ffi/unsafe)"

Can (should?) "(require mzlib/foreign) (unsafe!)" be changed to
"(require ffi/unsafe)" in the ImageMagick FFI .

Harry Spier

Posted on the users mailing list.