[racket] Looking for feedback on code style

From: Eli Barzilay (eli at barzilay.org)
Date: Thu Sep 9 11:26:01 EDT 2010

On Sep  9, David Van Horn wrote:
> [...] As for the structure of the code as given, I would use helper
> functions in place of the `let'.  The resulting code will be easier
> to read and the helper functions can be tested independently, making
> it easier to maintain and improve the likelihood that the whole
> program is correct; and correctness and ease of maintenance are
> important aspects of style.

Sounds like an overkill in this case, and for most values of
"idiomatic" I'd say that it'd make it less so.

          ((lambda (x) (x x)) (lambda (x) (x x)))          Eli Barzilay:
                    http://barzilay.org/                   Maze is Life!

Posted on the users mailing list.