[racket] alarm from download.plt-scheme.org

From: Neil Van Dyke (neil at neilvandyke.org)
Date: Thu Jul 29 13:03:12 EDT 2010

I think that the few warnings on "http://download.plt-scheme.org/" might 
alarm some people unnecessarily.

Someone just saw that page and was concerned that we might be using in 
production something that is no longer maintained/supported.  Which is 
considered very bad in some circles.

I explained the rebranding, assured him that we are still getting 
support for our use of 4.x, and that we can move to 5.x whenever is 

Perhaps the warnings could be rephrased?  Maybe tell people they 
probably want to get the latest, rebranded version, without scaring 
anyone who has 4.x in production?

(More context on production users moving between versions... The changes 
to move from 4.2.5 to 5.0 should be few and small for us, but moving 
between versions makes people nervous and takes considerable testing 
effort.  Also, each move to a new Racket version for us has to fit with 
our own release schedules and ebb and flow of available resources, so 
there will be a lag on uptake even when we see something in the latest 
Racket version that we would like to be using immediately and we expect 
no big problems by moving.)


Posted on the users mailing list.