[plt-scheme] Installing Datalog

From: Mark Engelberg (mark.engelberg at gmail.com)
Date: Sun Nov 1 21:59:54 EST 2009

Yes, I've restarted DrScheme several times since installing datalog.

My laptop went into standby in the middle of the first time I
installed it, so I'm wondering if the interruption left it in a state
where the language is in the cache, but it didn't complete the change
to the language menu.  That's why I uninstalled and reinstalled
Scheme.  But it didn't make a difference.  (Does the cache persist
between uninstalling and reinstalling?  If so, is there a way to
explicitly flush the planet cache?)

On Sun, Nov 1, 2009 at 6:41 PM, Carl Eastlund <carl.eastlund at gmail.com> wrote:
> Mark,
> You must restart DrScheme after installing a planet package for any
> changes in the Language menu to show up.  You might consider closing
> DrScheme and installing with this command line:
> planet install jaymccarthy datalog.plt 1 1
> Then start DrScheme and try the language menu.
> If you have been restarting DrScheme, I don't know what's wrong.  But
> it definitely won't update while it's running.
> Carl Eastlund
> On Sun, Nov 1, 2009 at 9:37 PM, Mark Engelberg <mark.engelberg at gmail.com> wrote:
>> In 4.2.2, I've run
>> #lang scheme
>> (require (planet jaymccarthy/datalog:1:1))
>> and Datalog is not appearing in my list of Experimental Languages.
>> I've tried uninstalling and reinstalling Scheme and repeating the
>> above steps, but to no avail.
>> Anyone know what I'm doing wrong?
>> Thanks,
>> Mark

Posted on the users mailing list.