[plt-scheme] DrScheme on SunRay, no fonts

From: Jarrett Lee (jalee at valdosta.edu)
Date: Tue Mar 3 13:12:43 EST 2009

I am working on setting up DrScheme for use in our SunRay lab. We are  
using RHEL 5 as an OS and Sun Ray Server Software 4.1.

 From the server's console (meaning the monitor plugged directly into  
the server), everything seems to work correctly and there are no issues.
See: http://www.valdosta.edu/~jalee/SunRay_Issue/RHEL_Server_Console.png

However, once we enable the SunRay thin clients and go login on one,  
the program stops displaying fonts. The File, Edit, View, etc. menus  
are gone except for the underscore and the titles for the Debug Check  
Syntax, etc. buttons are missing. Literally every where inside the  
window that there is supposed to be a letter or number, that letter or  
number is missing completely. Only the title bar of the window has any  
text in it.
See: http://www.valdosta.edu/~jalee/SunRay_Issue/RHEL_SunRay.png

Even the text in the "Are you sure you want to close" window is gone!
See: http://www.valdosta.edu/~jalee/SunRay_Issue/RHEL_SunRay2.png

What makes it even more strange is that the program works flawlessly  
if it is being displayed on a SunRay connected to a Solaris Sun Ray  
Server, only SunRays connected to Linux have this issue.

I have a support ticket with Sun, but they want us to try to find some  
sort of way to debug DrScheme. Is this possible? How would I enable  
such a thing? Any other suggestions for fixing this?

Jarrett Lee
System Services
Division of Information Technology
Valdosta State University

Posted on the users mailing list.