[plt-scheme] (newbie question) About Loop

From: Noel Welsh (noelwelsh at gmail.com)
Date: Fri Jun 12 17:03:09 EDT 2009

On Fri, Jun 12, 2009 at 9:47 PM, namekuseijin<namekuseijin at gmail.com> wrote:
> On Fri, Jun 12, 2009 at 4:56 PM, Neil Van Dyke<neil at neilvandyke.org> wrote:
>> "do" is standard for now, but I dream that we will someday right that wrong.
>>  "do" is a cryptic bit of syntactic sugar that gets in the way of refining
>> functional algorithms.
>> Instead of "do", I suggest using named-"let" unless "map", "for-each",
>> folds, etc. fit the problem naturally.
> Fact is:  do *is* named let, only more convenient and a bit more limited.

I've found comprehensions a better solution in almost all cases. For reals.


Posted on the users mailing list.