[plt-scheme] Re: Style question

From: Tomasz Skutnik (tomasz.skutnik at gmail.com)
Date: Wed Jun 3 16:11:53 EDT 2009

On Wed, Jun 3, 2009 at 9:12 PM, Eli Barzilay <eli at barzilay.org> wrote:
> Tomasz, in case you tried to use the macro I wrote and found that it's
> broken -- this is how it should be implemented instead:

Thanks guys for all your help. This discussion is very interesting and
I'm learning from it a lot.

As Ryan pointed I try to avoid "contortion of bindings". For me it's a
simple engineering trade off: every line of code is a cost (testing,
maintenance, documentation). I thought that changing function name
will be "one-form-no-brainer" (procedure-rename seemed like so), but
that didn't work. I don't complain. It's just a minor nuisance (if at

So leaving function name as is (create-pool) have negligible cost -
it's still perfectly clear what function does and I don't have to
"pollute" my code for unclear purpose (to provide negligibly "nicer"

Thanks for help. I appreciate it a lot.


Posted on the users mailing list.