[plt-scheme] Odd error message: is 4.0 really too old? :)

From: Carl Eastlund (cce at ccs.neu.edu)
Date: Thu Jun 12 10:19:28 EDT 2008

On Thu, Jun 12, 2008 at 12:52 AM, Will Farr <farr at mit.edu> wrote:
> Carl (and other Galore maintainers),
> I've been using Galore 3.6 with the pre-release PLT Scheme for a while now,
> and it seems to work fine.  There is a build error because the test suite
> depends on SchemeUnit 1.something, and that doesn't build on v4, but I
> haven't found any troubles with my modest usage of sets and tables.
> Should I be more careful, or could things really be working ok with version
> 4?

Hmm.  It sounds like Galore was depending on packages that would have
worked, if I hadn't disabled them when I added a new 4.0-compatible
version.  Furthermore, you installed your Galore before I changed
their availability (or possibly before the new planet server), so your
dependencies aren't broken.  If you installed from scratch, it
probably wouldn't work.


Posted on the users mailing list.