[plt-scheme] require planet packages, latest version?

From: Will M Farr (farr at MIT.EDU)
Date: Mon Apr 30 15:45:37 EDT 2007

> Yes, for instance.
> >(require (planet "roos.scm" ("oesterholt" "roos.plt" 1 0)))
> planet -p
> oesterholt roos.plt 1 5
> I must explicitly do:
> >(require (planet "roos.scm" ("oesterholt" "roos.plt" 1 6)))
> to get the latest version.

Isn't this because PlaneT first looks locally for a package which  
would satisfy the requirements?  So, if you ask for at least 1.0, and  
you have a .plt package for 1.5 on your system, it won't go online to  
check for 1.6?  If so, you could probably beat it by issuing

planet -d oesterholt roos.plt 1 6

to get a local copy of 1.6.  Then clearing the linkage table and  
requesting 1.0 or better would give you 1.6.


Posted on the users mailing list.