[plt-scheme] Failure installing plai-300.plt

From: Eric Hanchrow (offby1 at blarg.net)
Date: Sun May 21 04:02:27 EDT 2006

I pasted
into the "File/Install plt..." box (as directed on
http://www.cs.brown.edu/~sk/Publications/Books/ProgLangs/), and saw

    setup-plt: Setup version is 301.15
    setup-plt: Main collection path is
    setup-plt: Collection search path is 
    setup-plt:   /home/erich/.plt-scheme/301.15/collects
    setup-plt:   /usr/local/stow/plt/lib/plt/collects
    setup-plt: Unpacking PLAI from /tmp/tmp1148198246-705504686.plt
    string=?: expects type <string> as 1st argument, given: same; other arguments were: "collects"

     === context ===
    /usr/local/stow/plt/lib/plt/collects/setup/unpack.ss:45:2: shuffle-path
    /usr/local/stow/plt/lib/plt/collects/setup/unpack.ss:75:4: loop

... when you [find Lisp], many of your friends will become
rather... distant, as if you'd inexplicably stopped bathing.
        -- Steve Yegge

Posted on the users mailing list.