[plt-scheme] "broken compiled code" error

From: Kimberley Burchett (kim.burchett at gmail.com)
Date: Wed Jul 12 18:47:24 EDT 2006

On 7/12/06, Gregory Cooper <greg at cs.brown.edu> wrote:
> Would it make sense to use local-expand instead of expand-syntax?
> Replacing (expand-syntax #'expr) with (local-expand #'expr 'top-level
> '()) seems to get rid of the error, but I'm not sure if it does
> exactly what you want.

Works for me!  I gather that expand and expand-syntax aren't really
intended to be used inside macros.  Thanks.

Kimberley Burchett

Posted on the users mailing list.