[plt-scheme] Version Check

From: Eli Barzilay (eli at barzilay.org)
Date: Thu Apr 27 18:04:30 EDT 2006

On Apr 27, Anton van Straaten wrote:
> "Users who need to" to according to who?  You have done nothing to
> demonstrate nor establish this need from the user's perspective.
> You're attempting to solve a problem that many of your users clearly
> do not perceive.

Users who need to upgrade to avoid using old buggy software.  Those
that are unaware of reading through dialogs etc.  If such users would
have remained invisible as far as bug reports etc go, then there's
nothing to say, but that's not the case, and time is being wasted on
issues that shouldn't have been there.  This is why the maintenance
perspective matters.

On Apr 27, Jim Blandy wrote:
> On 4/27/06, Eli Barzilay <eli at barzilay.org> wrote:
> >
> > Any solution that involves explicit permission from the user, will
> > not get this permission from users who need to, thereby fail to do
> > its job.  If you don't accept that, you're not helping in finding
> > a solution.
> I read this as saying that DrScheme should do something that its
> users, if asked, would not give it permission to do.  I'm sure I'm
> misreading what you're saying.  What do you mean?

Users who don't care for reading dialogs won't care for giving
explicit permission, and won't care to check the site before
comlpaining, and they do.

But since this is about the fifth time I'm repeating this, I conclude
that this discussion has degraded to the kind of useless flamewar I
cannot stand.  So I'm removing myself from it and from decisions on
this issue.

          ((lambda (x) (x x)) (lambda (x) (x x)))          Eli Barzilay:
                  http://www.barzilay.org/                 Maze is Life!

Posted on the users mailing list.