[plt-scheme] Re: cannot require 19.ss (srfi)

From: Bradd W. Szonye (bradd+plt at szonye.com)
Date: Fri Jan 7 10:39:38 EST 2005

Bradd wrote:
>> I also complained about this many months ago, when I first joined
>> this list. After a bit of discussion and a lot of thinking about
>> alternatives, I've decided that the current approach is probably the
>> least of all evils. While it's obnoxious,

Matthias Felleisen wrote:
> I don't know for how long you have used and studied module systems,
> but I have been around them since 1982. And this is pretty much the
> best I have encountered. Scheme 48 probably runs a close second. And
> ML deserves mentioning too but for other reasons. -- Matthias

Not disagreeing with you -- I did say that it's the /least/ of all
evils, after all! Unfortunately, using different people's packages
inevitably leads to conflict, which means that there will always be some
unpleasantness to using a module system.
Bradd W. Szonye

Posted on the users mailing list.