[plt-scheme] DrScheme on a Unix server

From: Robby Findler (robby at cs.uchicago.edu)
Date: Mon May 17 11:29:31 EDT 2004

One thing is to check that the sysadmins followed the installation
instructions. If the ./install script wasn't run, you might see
behavior like you're describing.


At Mon, 17 May 2004 11:23:45 -0400, Prabhakar Ragde wrote:
>   For list-related administrative tasks:
>   http://list.cs.brown.edu/mailman/listinfo/plt-scheme
> If this isn't the right place to ask these questions, please accept my
> apologies and kindly redirect me.
> We have a large heterogeneous undergraduate computing environment
> consisting of a bunch of Unix boxes (mostly Suns running Solaris) that
> is managed by our IT people. I requested that they install DrScheme,
> but I have no control over it the way I do on my personal OS X and
> Windows machines. 
> After they had installed it, I tried it out (via Apple's X11 running
> on my desktop) and found it quite slow to load. I thought it might
> be due to the end-of-term student crunch, so I waited and tried it
> again just now. It gets partway through the load splash screen and
> seg-faults after displaying the HtDP icon and hanging there for a
> while. Once, I got a message about ProfessorJ needing to be able to
> change some files, but I have not been able to reproduce this. I
> have put in a bug report to our IT people, but I wondered if anyone
> had seen this behaviour before.
> Are there any gotchas I should be aware of in using DrScheme in an
> environment where I do not have administrator privileges? 
> Many thanks. --PR

Posted on the users mailing list.