[plt-scheme] Error compiling plt-scheme 208

From: Jamie Raymond <raymond@ccs.neu.edu> (jraymond at gmail.com)
Date: Thu Aug 5 10:20:38 EDT 2004

I'm the maintainer of the plot collection. We had a report like this
in the cycle leading up to 208, and I believe Matthew was going to
follow up with the reporter, but I never heard of any resolution. My
feeling is that it is a problem related to gcc-3.4.x and some change
in mzscheme that was made since 207 was released. Our build machine
(running gcc-3.3 under Fedora Core 2) doesn't tickle the bug, so until
we can investigate with gcc-3.4, can you use an earlier compiler


On Thu, 05 Aug 2004 13:23:09 +0200, Guillaume Rousse
<rousse at ccr.jussieu.fr> wrote:
>   For list-related administrative tasks:
>   http://list.cs.brown.edu/mailman/listinfo/plt-scheme
> Hello. I'm the maintainer for mandrake linux plt-scheme package. I have
> troubles building latest version (208).
> During make install stage:
> setup-plt: Post-Installing MrEd
> setup-plt: Done setting up
> setup-plt:
> setup-plt: Error during Compiling .zos for mzc
> (/home/guillomovitch/rpm/tmp/plt-208-buildroot/usr/collects/compiler)
> setup-plt:   private/compiled/const.zo::33183: read (compiled):
> ill-formed code
> setup-plt: Error during Compiling .zos for mzc private
> (/home/guillomovitch/rpm/tmp/plt-208-buildroot/usr/collects/compiler/private)
> setup-plt:   compiled/const.zo::33183: read (compiled): ill-formed code
> setup-plt: Error during Early Install for Plot library
> (/home/guillomovitch/rpm/tmp/plt-208-buildroot/usr/collects/plot)
> setup-plt:   make: Failed to make
> /home/guillomovitch/rpm/tmp/plt-208-buildroot/usr/collects/plot/src/fit/fit-low-level.o;
> collects/compiler/private/compiled/const.zo::33183: read (compiled):
> ill-formed code
> install: Errors in compilation process! (1)
> make[1]: *** [copy-finish] Error 1
> make[1]: Leaving directory `/home/guillomovitch/rpm/BUILD/plt/src'
> make: *** [install] Error 2
> error: Bad exit status from /home/guillomovitch/rpm/tmp/rpm-tmp.17742
> (%install)
> It may be related to gcc version (3.4.1). However, previous version
> (207) build fine with exactly the same configuration.

Posted on the users mailing list.