[plt-translators] english-string-constants.rkt update

From: Philippe Meunier (meunier at ccs.neu.edu)
Date: Wed Jul 31 07:08:33 EDT 2013

commit d94a4cd830d30b4681f952d5d94f5c358324cae3
Author: Matthew Flatt <mflatt at racket-lang.org>
Date:   Fri Jul 26 14:06:25 2013 -0600

    add migration panel to GUI package manager
    
    Also add "gui-pkg-manager" packages, including a "Racket Package Manager"
    GUI application (that needs a better icon).
    
    The package that supplies "Racket Package Manager" is not in the main
    distribution, since DrRacket already includes the GUI package manager.
============================================================
diff --git a/pkgs/string-constants-lib/string-constants/private/english-string-constants.rkt b/pkgs/string-constants-lib/string-constants/private/english-string-constants.rkt
index 441e625..b22dc6b 100644
--- a/pkgs/string-constants-lib/string-constants/private/english-string-constants.rkt
+++ b/pkgs/string-constants-lib/string-constants/private/english-string-constants.rkt
@@ -1785,6 +1785,7 @@ please adhere to these guidelines:
   (install-pkg-install-by-source "Install by Source") ; tab label
   (install-pkg-install-from-list "Install from List") ; tab label
   (install-pkg-install-installed "Installed")         ; tab label
+  (install-pkg-migrate-from "Migrate From")           ; tab label
   (install-pkg-menu-item... "Install Package...")
   (install-pkg-dialog-title "Install Package")
   (install-pkg-source-label "Package Source")
@@ -1796,7 +1797,7 @@ please adhere to these guidelines:
   (install-pkg-file-url "URL File")
   (install-pkg-github "Github")
   (install-pkg-name "Name (consulting resolver)")
-  (install-pkg-inferred-as "Type inferred to be ~a")
+  (install-pkg-inferred-as "Type inferred to be ~a") ; ~a gets install-pkg-{file,dir,...}
   (install-pkg-force? "Overwrite Existing?")
   (install-pkg-command-line "Equivalent command line invocation:")
   (install-pkg-error-installing-title "Error Installing Package")
@@ -1804,6 +1805,7 @@ please adhere to these guidelines:
   (install-pkg-install "Install")
   (install-pkg-update "Update")
   (install-pkg-remove "Remove")
+  (install-pkg-do-not-remove "Don't Remove")
   (install-pkg-action-inferred-to-be-update "Action inferred to be Update")
   (install-pkg-action-inferred-to-be-install "Action inferred to be Install")
   (install-pkg-default "Default")
@@ -1827,8 +1829,14 @@ please adhere to these guidelines:
   (install-pkg-abort-install "Abort Install")
   (install-pkg-abort-update "Abort Update")
   (install-pkg-abort-remove "Abort Remove")
+  (install-pkg-abort-migrate "Abort Migrate")
   (install-pkg-abort-generic-action "Abort Action")
   (install-pkg-show-all-options "Show All Options")
-  (pkg-manager-menu-item "Package Manager...")
+  (install-pkg-migrate-available-installations "Available Installations")
+  (install-pkg-inferred-as "Type inferred to be ~a") ; ~a gets install-pkg-{file,dir,...}
+  (pkg-manager-menu-item "Package Manager...")  
+  ;; where ~a gets an installation name:
+  (install-pkg-packages-for "Packages for ~a")
+  (install-pkg-really-remove-installation "Are you sure you want to remove all installed packages and information for ~a?")
   
   )


Posted on the translators mailing list.