And, given your post on the JIT optimizations for unsafe operations, I can see where they are truly unsafe (in terms of possibly crashing instead of just erroring.) When I make the changes to use the unsafe-fl/unsafe-fx operations, I&#39;ll change to using unsafe- as a prefix for the science collection operations.<br>
<br>Doug<br><br><div class="gmail_quote">On Sat, Oct 3, 2009 at 10:33 AM, Matthew Flatt <span dir="ltr">&lt;<a href="mailto:mflatt@cs.utah.edu">mflatt@cs.utah.edu</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="im">At Sun, 6 Sep 2009 18:59:01 -0600, Doug Williams wrote:<br>
&gt; Would it be better to call<br>
&gt; the operations &#39;unchecked-&lt;whatever&gt;&#39; instead of &#39;unsafe-&lt;whatever&gt;&#39;?<br>
&gt; Generally, we are calling the function because we know it is safe to avoid<br>
&gt; some constraint check - not because it is unsafe. Just a nit.<br>
<br>
</div>Despite the distinction between unsafety for performance and unsafety<br>
to get at new things, I like having all unsafe operations marked the<br>
same way. Also, &quot;unchecked&quot; doesn&#39;t sound dangerous enough to me.<br>
<br>
So, you make a good point, but I&#39;m still in favor of &quot;unsafe&quot;.<br>
<br>
</blockquote></div><br>