[racket-dev] XREPL and readline-6.*

From: Jon Rafkind (rafkind at cs.utah.edu)
Date: Mon May 7 23:13:01 EDT 2012

On 05/07/2012 07:01 PM, Eli Barzilay wrote:
> On January 11th, Eli Barzilay wrote:
>> 10 minutes ago, Marijn wrote:
>>> On 19-12-11 16:45, Marijn wrote:
>>>> that makes sense as my installed and the current upstream readline
>>>> version is 6.2. Any chance that could be fixed?
>>> This is still current,
>> Did you try to change the version in the source and see if it works?
> Is there anyone with readline v6 who can see if it's still compatible
> with our glue?

I have readline 6 and xrepl still works with it.

$ ls -l /usr/lib/libreadline.so
lrwxrwxrwx 1 root root 21 2011-08-01 00:09 /usr/lib/libreadline.so -> /lib/libreadline.so.6

Posted on the dev mailing list.