[racket-dev] current-*-port

From: Neil Van Dyke (neil at neilvandyke.org)
Date: Thu May 3 23:03:40 EDT 2012

Matthias Felleisen wrote at 05/03/2012 10:57 PM:
> I don't think Eli is proposing an elimination of the old names but supplementing the code base with new ones.
> I am in favor -- Matthias

Would be good to have a shorter naming convention for all parameters.  
The "current-" prefix is not short, but it's what I've been using when 
coding new parameters, because that's the convention.

Of course, a naming convention is much less important when we have 
static checking of argument types, but we usually don't.

Neil V.

Posted on the dev mailing list.