[racket-dev] current-*-port

From: Eli Barzilay (eli at barzilay.org)
Date: Thu May 3 15:48:17 EDT 2012

With the trend of having shorter names, I'll try suggesting it again.
Looking at some random slides (the ones from Matthew's talk), one
thing that is -- still -- very strikingly inconvenient is code like

  (parameterize ([current-error-port (current-output-port)])

IMO, anyone who is not coming from some kind of Scheme background
would view this as ridiculously long.  If they're renamed to the usual
names, things look much better:

  (parameterize ([stderr (stdout)])

Another point in favor: looking through my mailbox, it was very clear
that when people are talking about `current-error-port' etc, they
already use `stderr' etc in emails.  Another point for doing that in
this case but not in others: it is particularly bad in that it's three
words, and it's something that is much more common to deal with.

They could be provided as the old names too, for compatibility.

[Disclosure: I remembered suggesting it once, and finally found it --
I did this about 4 years ago.  The discussion didn't go beyond "use
M-/ in emacs", which is still very inconvenient.]

          ((lambda (x) (x x)) (lambda (x) (x x)))          Eli Barzilay:
                    http://barzilay.org/                   Maze is Life!

Posted on the dev mailing list.