[racket-dev] Bitwise operators

From: Asumu Takikawa (asumu at ccs.neu.edu)
Date: Wed Jun 27 03:46:27 EDT 2012

On 2012-06-19 17:54:48 -0400, Harry Spier wrote:
> 2. Why the names arithmetic-shift and integer-length instead of
> bitwise-shift and bitwise-length ?

Late reply, but here's a reason: SRFI-33[1] and SRFI-60[2] already use
these names. Although it looks like Racket's `arithmetic-shift` name
predates SRFI-33 (and was more or less tradition among Schemes). It also
differentiates from a `logical-shift`, should one ever be defined.

Apparently `integer-length` was also the traditional name by the time
the SRFIs rolled around.

[1]: http://srfi.schemers.org/srfi-33/srfi-33.txt
[2]: http://srfi.schemers.org/srfi-60/srfi-60.html


Posted on the dev mailing list.