[racket-dev] crash with subprocess

From: Tobias Hammer (tobias.hammer at dlr.de)
Date: Thu Aug 30 10:18:15 EDT 2012

It uses only a single place. The system is 32bit Linux:
Linux #1 SMP 2012-07-13 15:50:56 +0200 i686 i686 i386  


On Thu, 30 Aug 2012 15:17:05 +0200, Matthew Flatt <mflatt at cs.utah.edu>  

> It looks like we still have problems with the `subprocess'
> implementation that cooperates with places.
> Does your program use multiple places, or just one? If it uses multiple
> places, does it use `subprocess' in multiple places?
> Is your platform 32-bit Linux?
> At Thu, 30 Aug 2012 13:38:23 +0200, Tobias Hammer wrote:
>> Hi,
>> i am experiencing random crashes when using subprocess followed by a
>> subprocess-wait. My test program, that i call via subprocess is special,
>> in that it kills itself very fast with a sigkill after executing.
>> Unfortunately, i wasn't able to reproduce this behavior in a small  
>> sample
>> but i could record three different core dumps with full debug info
>> (attached).
>> I tested with my own build of git head and
>> All crashes/freezes are preceded by the message
>> "unexpected error from waitpid(138321448[1]): 10"
>> with a completely invalid pid argument to waitpid. The errno 10
>> is "No child processes".
>> What follows this message are random freezes (ctrl+c has no effect),
>> heap corruptions or segfaults.
>> I hope the supplied information is enough to locate whatever goes wrong,
>> otherwise i can, of course send in more.
>> Tobias

Tobias Hammer
DLR / Institute of Robotics and Mechatronics
Muenchner Str. 20, D-82234 Wessling
Tel.: 08153/28-1487
Mail: tobias.hammer at dlr.de

Posted on the dev mailing list.