[racket-dev] DrRacket compilation bug

From: José Lopes (jose.lopes at ist.utl.pt)
Date: Wed Dec 7 02:16:53 EST 2011


I think this problem was my fault, because the code created a loading 
cycle with dynamic-require.


On quarta-feira, 7 de Dezembro de 2011 14:43:15, José Lopes wrote:
> Hello,
> I am using DrRacket version checked out from the Git repo.
> I have also modified the MysterX source code. But this modification 
> was already submitted as a patch which was accepted by Matthew.
> I have been developing a library for quite some time now.
> Today I was trying to compile/check-syntax a program that requires 
> that library and when I pressed the Run button DrRacket showed the 
> interactions window with no prompt and seemed to stay that way (my 
> guess forever). So I restarted DrRacket, retried the compilation and 
> got the same result. Then, I deleted some "compiled" directories from 
> my library, restarted DrRacket, hit the Run button and DrRacket 
> crashed. The last attempt to restart DrRacket/compile worked fine.
> I know it is not much information, but I hope it helps you find the 
> problem.
> Regards,
> José

José António Branquinho de Oliveira Lopes
58612 - MEIC-A
jose.lopes at ist.utl.pt

Posted on the dev mailing list.