[racket-dev] racket-5.1{, .0.6} not building foreign interface not supported

From: Marijn (hkBst at gentoo.org)
Date: Fri Apr 8 06:45:50 EDT 2011


subject is valid for both its meanings:

1) my build fails and complains "make-stubborn-will-executor: foreign
interface not supported for this platform"

2) it seems impossible to disable foreign as I get this even if I pass
--disable-foreign to configure

See attached build log.

My platform is amd64 GNU/Linux and I have libffi installed from distro


PS It seems that configure.{ac,in} is missing from the source tarball.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: build.log
URL: <http://lists.racket-lang.org/dev/archive/attachments/20110408/294e9798/attachment.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
URL: <http://lists.racket-lang.org/dev/archive/attachments/20110408/294e9798/attachment.sig>

Posted on the dev mailing list.