[racket-dev] string<? error

From: Stephen Chang (stchang at ccs.neu.edu)
Date: Thu Oct 7 16:49:39 EDT 2010

> I don't suppose you get a stacktrace with the error?

No, it's just the error message. Although it seems to only happen in
drracket. I cant recreate the error from the command line.

> On Thu, Oct 7, 2010 at 3:35 PM, Stephen Chang <stchang at ccs.neu.edu> wrote:
>> Has anyone seen an error like this before:
>> string<?: expects type <string> as 1st argument, given: #f; other
>> arguments were: "dcdf0433aca16ea2f5db9a003821f56a718d2da5"
>> I'm using an older version of racket,, but I havent seen the
>> error until recently. I get the error when I run certain files in
>> drracket. I started getting the error after making some changes to
>> stepper code (for example stepper/private/reconstruct.rkt) but I dont
>> think the error is due to any code I modified because I dont use the
>> string<? function anywhere and because I get the same error when I run
>> base racket files like racket/private/small-scheme.rkt and
>> racket/private/cond.rkt.
>> Also, I ran setup-plt and the error still occurs. Anyone have any
>> ideas where the error is coming from?
>> _________________________________________________
>>  For list-related administrative tasks:
>>  http://lists.racket-lang.org/listinfo/dev

Posted on the dev mailing list.