[plt-dev] performance-oriented unsafe operations (v4.2.1.8)

From: Doug Williams (m.douglas.williams at gmail.com)
Date: Sat Oct 3 12:33:12 EDT 2009

And, given your post on the JIT optimizations for unsafe operations, I can
see where they are truly unsafe (in terms of possibly crashing instead of
just erroring.) When I make the changes to use the unsafe-fl/unsafe-fx
operations, I'll change to using unsafe- as a prefix for the science
collection operations.


On Sat, Oct 3, 2009 at 10:33 AM, Matthew Flatt <mflatt at cs.utah.edu> wrote:

> At Sun, 6 Sep 2009 18:59:01 -0600, Doug Williams wrote:
> > Would it be better to call
> > the operations 'unchecked-<whatever>' instead of 'unsafe-<whatever>'?
> > Generally, we are calling the function because we know it is safe to
> avoid
> > some constraint check - not because it is unsafe. Just a nit.
> Despite the distinction between unsafety for performance and unsafety
> to get at new things, I like having all unsafe operations marked the
> same way. Also, "unchecked" doesn't sound dangerous enough to me.
> So, you make a good point, but I'm still in favor of "unsafe".
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.racket-lang.org/dev/archive/attachments/20091003/30735a32/attachment.html>

Posted on the dev mailing list.